Sign in to follow this  
Followers 0
njresler

Mylink Steering Wheel controls.

16 posts in this topic

Today my steering wheel controls stopped working? I turned off car a couple of times and hoped it would reset but no luck. Then when I put it in reverse now it tries to pick up back up camera which I don't have. 

Share this post


Link to post
Share on other sites

Only for the radio. Cruise works. 

Share this post


Link to post
Share on other sites

Also no temp on the display. Wish I know what happened and also wish I actually had the backup camera

Share this post


Link to post
Share on other sites

Not sure what is going on here, but did you get the MyLink recall update done...if so that could be the problem. If not then try disconnecting the battery overnight.

Share this post


Link to post
Share on other sites

I did the update. But a month or so ago. Just now having issues. It's super frustrating. I don't want to pay the dealer for something simple. I'll try disconnecting the battery.  

Share this post


Link to post
Share on other sites

Disconnecting batter didn't work. It's either a fuse or wiring?  Unless its software. It is strange that all of a sudden it tries to use a backup camera

Share this post


Link to post
Share on other sites

Others have had this issue after the update...sometimes right away sometimes after a while..Take it back in..warranty issue.

Share this post


Link to post
Share on other sites

 I called the dealer they have no knowledge of such defect with the new update. But I'm going to call the service manager because I know him personally and see if he has any information. 

Share this post


Link to post
Share on other sites

My 2013 2 lt with manual trans started this yesterday. Can't control the mylink from the steering wheel controls no outside temperature reading on the radio and when I backup it says service back up camera which it doesn't have. Recall was done several months ago for the radio no problems til just now. Any fixes yet anyone heard? I plan on taking it in to see what they say

Share this post


Link to post
Share on other sites
3 hours ago, Chippy848 said:

My 2013 2 lt with manual trans started this yesterday. Can't control the mylink from the steering wheel controls no outside temperature reading on the radio and when I backup it says service back up camera which it doesn't have. Recall was done several months ago for the radio no problems til just now. Any fixes yet anyone heard? I plan on taking it in to see what they say

 

That's weird that it was months ago and now this. Are you sure you have not done anything recently?

Share this post


Link to post
Share on other sites

Others have reported similar issues after the MyLink recall service..Never had mine done as it has no symptoms that the recall is for. Only recall I have had in over 100Kmi is the PCV replace recall at about 30Kmi. Car still looks and runs like new...2013 1LT auto tranny with 106Kmi on it.

Share this post


Link to post
Share on other sites

Nope I haven't done anything lately. From the research I have done it is caused by installing the wrong update for the recall for mylink. I only drive the car once every week or two my better half runs the wheels off it though and she find the notice it. I could of swore everything worked fine that sat morn then quit working half way through are trip, I'm going to talk to my service manager to get it looked into and will keep you posted when I do 

Share this post


Link to post
Share on other sites

Ok, sounds good. 

Share this post


Link to post
Share on other sites

 I took it into the dealer they redid the update and fixed it 

Share this post


Link to post
Share on other sites

Yes picked mine up yesterday they said they had to recalibrate the update. All is good and no charge!

Share this post


Link to post
Share on other sites

SO, a little over a year hasn’t gone by since this happened and was fixed. Last night after turning my car off for a few minutes upon restarting it has happened again. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0