Sign in to follow this  
Followers 0
cimera

AC has a leak, when i recharged I heard a hissing sound and it stopped working again within a couple of days.

3 posts in this topic

When i first got the car the AC wasnt working, I thought maybe it was just low on coolant I got it recharged and after a couple of days when I turned the AC on, it made a hissing sound and eventually stopped blowing cold again. Is this a common issue? I could hear the hissing from inside the cabin, do you think theres a leak in the line or could it be a compressor?

 

I have a UV torch but I don't really even know where the compressor/condensor is in the car to check for a leak. Does an AC repair run a lot of money?

Share this post


Link to post
Share on other sites
   


AC repair can be very costly. Probably one of the reasons they got rid of the car instead of fixing it. If the leak is inside then it could be the evaporator or the lines going to it. Usually that means a complete tear down of the dash. Did you smell or see refrigerant or oil? 

Share this post


Link to post
Share on other sites

Posted (edited)

I couldn't smell anything, I could just hear a hissing sound. It didn't happen as soon as I got it recharged it worked fine for like 2 days but the hissing was a couple of days afterwards, which was strange.

Edited by cimera

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0