3 posts in this topic

Hello, I've been scouring the internet and I cannot find a suitable answer to this issue. Please give some insight if you have any.

 

First my 2014 Chevy Spark doesn't blow air at all, no temperature at the vents, no settings work whatsoever, tried all options. Tested all fuses I have been able to access from the fuse boxes.

 

Two possibilities I have found that seem most likely: A/C fuse relay bad or blower motor resistor bad.

 

For the A/C relay specifically I'm looking for help: when you go to the fuse box diagram under the hood it says A/C relay but it has dotted lines around it. The location has a plastic cover that is part of the fuse box and isn't removable. Literally there is no relay there. No one online seems to have any answer for this.

 

Please can someone just tell me where this relay is? Please don't say just remove it it literally isn't there where is it? Please don't say just check something else can someone just answer specifically how to access the A/C relay?? I know people are used to older models having relays right there and don't understand why someone asking - please don't just blow off the question

20190309_122521.jpg

20190309_122524.jpg

Share this post


Link to post
Share on other sites

Hi,

Its basically the dotted part are directly soldered on the board of fuse-relay box. Now why, GM can only answer.

I can suggest if you have doubt on ac relay, you need one person help. Turn on car, open the hood and the relay box and ask someone to turn ac on. You must be able to hear the click of relay activation. This is my presumption, I never tried this as never encountered this. But yes this is how relay works.

Safety point - ensure parking brake applied.

Pic is for reference, I took mine relay bord's just 2 week back as fog relay was loosing contact. Don't try to dismantle unless you are really very good to electronics.:redcard:

IMG_20190311_001951030~2.jpg

Share this post


Link to post
Share on other sites

Posted (edited)

I know you said dont suggest something else but you are going down the wrong path. It won't be the blower motor resistor or ac relay. The resistor gets bypassed on the top speed. If it worked on the top speed but no the other then thats a sign of a bad resistor. AC relay only controls the ac clutch. There is also a ac fan relay, not sure that our cars have one, but it commands the cooling fan and again has nothing to do with the blower. The blower motor is on a separate circuit since it has to work whether AC or heat is on or just circulating air. Its either a blower fuse, switch or the motor has went out. Easiest way to start troubleshooting  is to see if you are getting voltage at the motor and work your way back. 

Edited by Ray Dockrey

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now