Sign in to follow this  
Followers 0
cosmooo

AC won't turn on (no light/compressor/anything) after recall service

5 posts in this topic

Has anyone else encountered this? I've browsed through the forums, and I haven't found anything similar yet.

In short: AC was working last summer. Took my 2013 Spark in for other recall services this winter, and they did the 13434 AC service while it was there. Didn't try to use the AC again until recently (getting hot here), and the AC button doesn't even work.

No AC button light, the compressor doesn't seem to kick on, and the air is warm, warm, warm.

Checked various fuses, but everything seems to be in order. Even tried adding freon, as I've seen mentioned elsewhere, but that didn't do anything either.

Tried taking it to a different dealer, but they wouldn't even look at it (since the other dealership checked off the 13434 recall service) without a $140 service fee.

Any ideas?

Thanks!

Edited by cosmooo

Share this post


Link to post
Share on other sites

Hmm isn't it still under warranty? Unless you have over 36,000 miles on it I would think so.

Anyway you should take it back to the dealer that did the recall. Sounds like they may have messed something up and they would be responsible to fix it.

Share this post


Link to post
Share on other sites

If the light within the A/C button does not come on, but the A/C compressor comes on, it is a bulb failure. In your case the A/C compressor does not come on so my best guess is the switch itself is defective. I would have the dealer look at that and is a warranty item. If you are past warranty a garage that has some electronic/electrical knowledge could easily check that out for you and replace the switch with an aftermarket unit.

NOTE:There is a replaceable A/C relay in the engine compartment large fusebox that, if it has failed will also cause the A/C not come on. The location is marked on the enclosed image.post-1288-0-21334900-1433152257_thumb.jp

Share this post


Link to post
Share on other sites

Update:

We finally managed to get it to the dealer. Brought it in a couple of weeks ago, and they ordered some parts and told us to come back a week later to install.

We did, and they did...and it still doesn't work. It's been at the dealership for a week undergoing diagnostic or some such thing. The dealers appear to be stumped, and we have no idea when we're getting our car back.

They did give us a loaner...it's not as easy to parallel park on a crowded city street, but at least the AC works.... :\

Any ideas what we can expect if they just can't manage to fix it?

Edited by cosmooo

Share this post


Link to post
Share on other sites

pretty sure if they cant fix it they have to give you a new car or something.. could be wrong though but wouldnt that be nice. I would think if you gut he system and put in all new parts it would work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0