sura13mac

Stalling when stopped

28 posts in this topic

UPDATE! After much time diagnosing with my laptop scan tool, I was able to prevent the 2014 Spark from stalling during initial acceleration and dying when coming to an idle. I discovered that when I turned the fuel control loop off the car would idle and run perfect.

As a temporary fix to treat the symptoms and keep from getting in or causing an accident, I unplugged the upstream O2 sensor. It has been about 2 weeks and the car has been running great. I know this is just a temp fix and I still need to find out why this causes the car to run perfect.

The O2 sensor was the first item I changed when I first got the car and started troubleshooting . Now, the only DTC I get is for O2 sensor.

Anyone have any ideas as to what could cause this power-train issue? Fuel injectors? Coil Pack? Spark Plugs? The upstream O2 sensor appears to be indicating a rich mixture most of the time like there is some inefficient combustion taking place and not necessarily a sensor problem.

Share this post


Link to post
Share on other sites

Fuel control loop?

Share this post


Link to post
Share on other sites

Posted (edited)

My 2013 chevy spark is having the same issues... And the shops the dealership is sending me to says they cant get it to do it... Is there a recall on it for stalling and stuttering???

Edited by Naylarae24

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now